ECGrid Forums  

Go Back   ECGrid Forums > Electronic Commerce > ECGridOS > ECGridOS Developer

ECGridOS Developer Development related posts.

Reply
 
Thread Tools Display Modes
  #1  
Old 03-28-2013, 10:56 AM
joblesspoet joblesspoet is offline
New Member
 
Join Date: Mar 2013
Posts: 12
Default User APIs

Hi Todd,
Thanks for your comments. I'm calling web service UserList which will show the user in the network/sessionID. On web service response it is returning me 3 users but on NetEDI Dashboard i can see 5 user.

Code:
https://ecgridos.net/v3.0/prod/ecgridos.asmx?op=UserList
if i use this call at this url it is also giving me 3 users.

In SessionID parameter i'm passing session id and In the Name parameter i'm not passing any thing.

Can you explain me why I'm seeing 3 users instead of 5. I'm using credentials provided my client.

Regards
Reply With Quote
  #2  
Old 03-28-2013, 11:30 AM
Todd Gould's Avatar
Todd Gould Todd Gould is offline
Loren Data Corp.
 
Join Date: May 2005
Location: Loren Data Corp.
Posts: 303
Send a message via Skype™ to Todd Gould
Default

Private Message me your LoginName so I can test from my end and see what is going on.

I will also request that someone from NetEDI join this discussion.

-=tg=-
Reply With Quote
  #3  
Old 04-04-2013, 06:24 AM
joblesspoet joblesspoet is offline
New Member
 
Join Date: Mar 2013
Posts: 12
Default User APIs

Hi Todd,

In my previous post i asked a question. Whey i'm getting 4 user from "UserList" call. I noticed it now if i'm use "https://ecgridos.net/v3.0/prod/ECGridOS.asmx/UserList" and provide session id it will returns 4 users.
But if i use "https://ecgridos.net/v2.3/prod/ECGridOS.asmx/UserList" it returns me actual users (right now in my case we have 8 users ). I need to know why this happening? Is there any thing special in v3.0?


I noticed it now that's y I'm posting here.

Regards
Reply With Quote
  #4  
Old 04-04-2013, 09:37 AM
Todd Gould's Avatar
Todd Gould Todd Gould is offline
Loren Data Corp.
 
Join Date: May 2005
Location: Loren Data Corp.
Posts: 303
Send a message via Skype™ to Todd Gould
Default User APIs

This thread is specific to the set of User APIs. Please post the specific API in the title of your post to help others who have similar questions.

-=tg=-
Reply With Quote
  #5  
Old 04-04-2013, 09:46 AM
Todd Gould's Avatar
Todd Gould Todd Gould is offline
Loren Data Corp.
 
Join Date: May 2005
Location: Loren Data Corp.
Posts: 303
Send a message via Skype™ to Todd Gould
Default

Quote:
In seeing strange thing in web service "UserList" response.I have 8
users in out account. I noticed it now if I use
"https://ecgridos.net/v3.0/prod/ECGridOS.asmx/UserList" and provide
session id it will returns 4 users.
But if i use "https://ecgridos.net/v2.3/prod/ECGridOS.asmx/UserList" it
returns me actual users (right now in my case we have 8 users ). I need
to know why this happening? Is there any thing special in v3.0?
This behavior is as excpected.

In v2.3 the UserList() call from an Admin level user logged into the root (0) directory would list all users in all mailboxes.

In v3.0 this was corrected to show only users assigned to the root (0) mailbox. To see all users in all mailboxes, use the UserListEx() API with MailboxID := -1, which is the same functionality of UserList() in v2.3 under these circumstances.

-=tg=-
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 09:07 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
ECGrid® is a registered service mark of Loren Data Corp.