ECGrid Forums  

Go Back   ECGrid Forums > Electronic Commerce > ECGridOS > ECGridOS Developer

ECGridOS Developer Development related posts.

Reply
 
Thread Tools Display Modes
  #1  
Old 03-22-2013, 09:20 AM
Todd Gould's Avatar
Todd Gould Todd Gould is offline
Loren Data Corp.
 
Join Date: May 2005
Location: Loren Data Corp.
Posts: 303
Send a message via Skype™ to Todd Gould
Lightbulb How do I get started?

This thread is dedicated to starting from the beginning. Ultimately, the questions, answers and information in this thread will be used to produce the first difinitive How To paper for ECGridOS.

Your participation as both questioner and answerer are greatly apprecaited!

Thanks!

-=tg=-
Reply With Quote
  #2  
Old 03-25-2013, 02:24 AM
joblesspoet joblesspoet is offline
New Member
 
Join Date: Mar 2013
Posts: 12
Default

Hi Todd,

It's great that you started this thread for newbies. I'm one of them. If you will provide a short details how to start that will be great

Thanks
Reply With Quote
  #3  
Old 03-25-2013, 06:05 AM
joblesspoet joblesspoet is offline
New Member
 
Join Date: Mar 2013
Posts: 12
Default How to get ECGridID

Hi,

Can anyone explain how we get ECGridID and Qualifier ID?

Thanks

Last edited by joblesspoet; 03-25-2013 at 06:07 AM. Reason: missone one thing QID
Reply With Quote
  #4  
Old 03-27-2013, 07:58 AM
joblesspoet joblesspoet is offline
New Member
 
Join Date: Mar 2013
Posts: 12
Default Facing issue using web services

Hi Todd,

I'm trying to access web service using PHP (nusoap PHP) library. On Login Call i'm facing this issue:

Code:
'wsdl error: Getting https://ecgridos.net/v2.3/prod/ECGridOS.asmx?WSDL - HTTP ERROR: cURL ERROR: 28: Operation timed out after 30015 milliseconds with 179871 out of 563173 bytes received<br>url: https://ecgridos.net:443/v2.3/prod/ECGridOS.asmx?WSDL<br>content_type: text/xml; charset=utf-8<br>http_code: 200<br>header_size: 233<br>request_size: 145<br>filetime: -1<br>ssl_verify_result: 20<br>redirect_count: 0<br>total_time: 30.015<br>namelookup_time: 0<br>connect_time: 10.187<br>pretransfer_time: 11.076<br>siz'... (length=745)
kindly help me
Thanks
Reply With Quote
  #5  
Old 03-27-2013, 11:03 AM
Todd Gould's Avatar
Todd Gould Todd Gould is offline
Loren Data Corp.
 
Join Date: May 2005
Location: Loren Data Corp.
Posts: 303
Send a message via Skype™ to Todd Gould
Default

First, please use the new v3.0 URL:
https://ecgridos.net/v3.0/prod/ecgridos.asmx
As for the partuclar error, when I copied the URL you provided and put it right into my browser, it came up with the WSDL w/o a problem.

I'm wondering if this was simply an Internet connectivity issue as it looks like you received 179,871 ouf of 563,173 bytes.

-=tg=-
Reply With Quote
  #6  
Old 04-04-2013, 09:36 AM
Todd Gould's Avatar
Todd Gould Todd Gould is offline
Loren Data Corp.
 
Join Date: May 2005
Location: Loren Data Corp.
Posts: 303
Send a message via Skype™ to Todd Gould
Default Clarification on this thread

This particular thread will be used for general questions on how to get started and the basics of ECGridOS.

I am setting up specific threads for questions on Users, Mailboxes, Trading Partners/Qualifier IDs, Interconnects, Parcel Upload/Download, etc.


So post your function specific questions in those threads and general questions here.

Thanks.

-=tg=-

Last edited by Todd Gould; 04-04-2013 at 09:49 AM.
Reply With Quote
  #7  
Old 03-18-2014, 02:08 PM
jeremydegardeyn jeremydegardeyn is offline
New Member
 
Join Date: Mar 2014
Posts: 7
Default Sample Console Application - Cannot Declare Object

Hello,

I'm trying to run sample console application provided using VS 2008, VB.NET. I haven't been able to run it past the object declaration. I did add the web reference, v3. It does compile. Intellisense does find methods. The code example posted, though v2, shows the object declaration as:

Public ecgridos As New Net.ecgridos.ECGridOSAPIv2

When I use that it doesn't recognize it. The closest thing intellisense finds is

Public ecgridos As New Net.ecgridos.ECGridOSAPIv3SoapClient

But when I run the application it breaks and I get this error:

An unhandled exception of type 'System.TypeInitializationException' occurred in Microsoft.VisualStudio.HostingProcess.Utilities.dl l

Another thing to note would be that though it wasn't documented I had to add System.Web as a reference.

Thanks in advance for any help

Jeremy
Reply With Quote
  #8  
Old 03-18-2014, 03:17 PM
Todd Gould's Avatar
Todd Gould Todd Gould is offline
Loren Data Corp.
 
Join Date: May 2005
Location: Loren Data Corp.
Posts: 303
Send a message via Skype™ to Todd Gould
Default

Jeremy,

I have done VS2008 work extensively with ECGridOS. In fact, ECGridOS is written in VS2008.

I would need to confirm the web service URL. I suspect you are using https://ecgridos.net/v2.3/prod/ecgridos.asmx. I am encouraging all new developers to use https://ecgridos.net/v3.0/prod/ecgridos.asmx.

Once you can confirm the URL, can you post a code snip-it here so I can see it? I can also jump on Skype or other desktop sharing system to take a look at what is going on and provide suggestions.

As for system.web as a reference, I have never had to manually add that. Looking at a few applications I see the following related reference which were added automatically:

System.Web.Extensions

Perhaps the way the web service was added didn't quite get it all lined up. A quick look will get you on your way.

-=tg=-
Reply With Quote
  #9  
Old 03-18-2014, 03:43 PM
jeremydegardeyn jeremydegardeyn is offline
New Member
 
Join Date: Mar 2014
Posts: 7
Default

I confirmed the url, even started over. Because of the object declaration it doesn't compile, doesn't recognize ECGridOSAPIv3:


Imports System.Web.Services.Protocols
Imports System.Xml

Module Module1
Public ecgridos As New Net.ecgridos.ECGridOSAPIv3

Sub Main()
Console.WriteLine("Hello World")
End Sub

End Module


Like I said I can change it to something like

Public ecgridos As New Net.ecgridos.ECGridOSAPIv3SoapClient

but then when I try to run the whole example I get an initialization error.

Jeremy
Reply With Quote
  #10  
Old 03-18-2014, 03:46 PM
Todd Gould's Avatar
Todd Gould Todd Gould is offline
Loren Data Corp.
 
Join Date: May 2005
Location: Loren Data Corp.
Posts: 303
Send a message via Skype™ to Todd Gould
Default

Something is not set up right as I cannot even access ECGridOSAPIv3SoapClient in my environment.

Can we set up a time to share your desktop so I can see what is going on?

-=tg=-
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 11:21 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
ECGrid® is a registered service mark of Loren Data Corp.